Pythonのバージョン

TensorFlowも仮想Python環境も、現時点でリリースされているPython2.7およびPython3.6のどちらでも利用可能ですが、別段の理由がなければPython3系での使用を前提にした方が良いです。実際にアメリカ方面の研究者・エンジニアが発表するGitHubに置いたコードを読んでみると、Python3系での稼働が前提としているものが多く目に付きます。この趨勢を考えると、別段の理由がない限り彼らと足並みをそろえてPython3系でセットアップすべきと考えます。